You need to enable JavaScript to run this app.
导航
SetCenBandwidthPackageRenewal
最近更新时间:2024.04.22 17:44:12首次发布时间:2024.01.09 07:27:01

调用 SetCenBandwidthPackageRenewal 接口,设置包年包月类型带宽包的续费类型。

调试

请求参数

参数名称
类型
是否必选
示例值
描述
ActionStringSetCenBandwidthPackageRenewal要执行的操作,取值为SetCenBandwidthPackageRenewal。
VersionString2020-04-01API版本信息,当前版本为2020-04-01。
CenBandwidthPackageIdStringcbp-bp1o94dp5****带宽包的ID。您可以调用DescribeCenBandwidthPackages接口获取带宽包ID。

RenewType

String

Auto

带宽包实例的续费类型。取值如下:

  • Manual:手动续费。
  • Auto:自动续费。
  • NoRenew:不续费。

RenewPeriod

Integer

1

单次自动续费的时长,单位为月。
取值包括1~3,6和12,默认值为1。

说明

RenewType配置为Auto时生效。

RemainRenewTimes

Integer

1

自动续费的次数。
取值包括-1和1~100,默认值为-1,表示自动续费无限次。

说明

RenewType配置为Auto时生效。

返回参数

参数名称
类型
示例值
描述
RequestIdString2021081115253901022514606****请求ID。

请求示例

GET /?Action=SetCenBandwidthPackageRenewal&Version=2020-04-01&CenBandwidthPackageId=cbp-bp1o94dp5****&RenewType=Auto HTTP/1.1
Host: open.volcengineapi.com
Service: cen
Region: cn-beijing

返回示例

{
    "ResponseMetadata": {
        "RequestId": "2021081115253901022514606****",
        "Action": "SetCenBandwidthPackageRenewal",
        "Version": "2020-04-01",
        "Service": "cen",
        "Region": "cn-beijing"
    },
    "Result": {}
}

错误码

下表为您列举了该接口与业务逻辑相关的错误码。公共错误码请参见公共错误码文档。

HttpCode错误码错误信息描述
400InvalidCenBandwidthPackage.ModifyRenewalSettingsModify renewal settings failed.修改自动续费配置失败。
400InvalidCenBandwidthPackage.RemainRenewTimesMalformedThe specified RemainRenewTimes is invalid.指定的自动续费剩余次数无效。
400InvalidCenBandwidthPackage.RenewPeriodMalformedThe specified RenewPeriod is invalid.指定的续费周期无效。
400InvalidCenBandwidthPackage.RenewTypeMalformedThe specified RenewType is invalid.指定的续费类型无效。
400UnsupportedOperation.CrossBorderBandwidthPackageThe specified request is denied because the bandwidth package is a cross-border bandwidth package.指定带宽包为跨境带宽包,不支持当前操作。
400FailedOperationFailed to obtain CEN bandwidth package billing information.获取带宽包计费信息失败。
404InvalidCenBandwidthPackage.NotFoundThe bandwidth package of the specified geographic regions does not exist.指定的带宽包不存在。