You need to enable JavaScript to run this app.
优惠活动
大模型
产品
解决方案
定价
更多

pip安装airflow-pentaho-plugin时提示找不到可用setuptools-git-version版本

核心故障根因定位

你当前的安装链路本身网络连通性是正常的——从xmltodict依赖可以正常识别为已安装的反馈来看,代理链路的基础请求能力没有问题,报错的核心触发点是版本匹配链路的多重不兼容:

  • setuptools-git-version是2019年停更的老依赖包,官方没有发布适配Python3.9的预编译安装包,你当前使用的pip 21.0.1版本匹配逻辑过旧,会在版本校验阶段直接过滤所有不匹配Python版本的候选包,最终判定为无满足要求的可用版本。这也是你之前更换为python setup.py install安装方式后仍然报完全一致错误的原因——两种安装方式都会触发同一个依赖的版本校验逻辑。
  • 你配置的企业代理对应的内部pip源,大概率没有同步收录这个低下载量的老依赖包,即使pip版本升级后,也会因为源索引缺失找不到对应包。
  • RHEL 6.9系统自带的glibc、openssl版本过低,和pip 21.0.1的版本校验逻辑存在隐性兼容问题,会进一步放大版本匹配的报错概率。
可落地的分步解决流程

按照顺序执行以下操作,即可打通安装流程:

  • 升级pip到兼容当前RHEL6.9 + Python3.9环境的最高稳定版本,解决旧版pip的版本匹配逻辑bug,执行命令:
    python3.9 -m pip install --upgrade pip==21.3.1 --proxy=http://proxy:port
  • 手动预安装缺失的setuptools-git-version依赖,绕开目标插件自动安装时的匹配逻辑,执行命令:
    sudo pip install setuptools-git-version==1.0.4 --proxy=http://proxy:port
  • 如果上一步仍提示找不到对应包,临时指定公网PyPI索引做拉取兜底,保持代理链路不变:
    sudo pip install setuptools-git-version==1.0.4 --proxy=http://proxy:port --index-url=https://pypi.org/simple/
  • 降级setuptools到兼容版本,解决老依赖和新版setuptools的接口拦截问题,执行命令:
    sudo pip install setuptools==57.5.0 --proxy=http://proxy:port
  • 重新执行目标插件的安装命令:
    sudo pip install airflow-pentaho-plugin --proxy=http://proxy:port
安装过程的避坑提示
  • 不要重复使用python setup.py install的安装方式,该方式不会自动校验依赖路径和版本兼容性,在RHEL6.9环境下极易出现安装完成后模块无法导入的隐性故障。
  • 如果预安装setuptools-git-version时触发git相关报错,需确认系统层面已安装git工具,该依赖的版本生成逻辑是直接调用本地git命令读取提交信息,缺失系统git会导致后续构建环节直接失败。
  • 安装过程中如果出现TLS握手类报错,不要直接关闭pip的证书校验选项,可单独为当前Python3.9环境配置系统CA证书路径即可解决。

内容的提问来源于stack exchange,提问作者Pavan Sharma

相关产品推荐
方舟 Agent Plan

超全模态模型 × Harness 升级,最新支持 Deepseek-V4.1-Flash、GLM-5.3 系列、Doubao-Seedream-5.0-pro、Kimi-K3 (部分), 限时 9.9 元起

最近更新时间:2026.10.29 17:45:10